Follow Topcon Surveying Hub

Topcon Positioning Support Hub  is a dedicated place for Land Surveyors United  members who use Topcon Instruments in the field to share experiences and support one another with troubleshooting issues. This group is specifically for discussions and tutorials related to Topcon Land Surveying Equipment.

Please Note: Land Surveyors United Community  is not directly affiliated with Topcon and all logos and imagery are copyright of respective owners.  This group is for educational purposes and social support with Topcon Equipment.

133 Topcon Users
👉️Join this Hub
Retired Surveyor

Topcon GTS-4 problem

Hi:

I have a GTS-4 which has served me well for a number of years. Recently, I now have problems getting it to switch on. When connected EITHER to the handle battery OR the 12v car battery adaptor (both of which are fully charged), the screen shows me "battery empty", which is clearly not the case.

Enough juice gets through to give me this permanent message. The screen works fine otherwise, beeping for a second and showing me the full panel, but then drops to the battery empty message.

Any suggestions?.

Santiago Chile

You need to be a member of Land Surveyors United - Global Surveying Community to add thoughts!

Join Land Surveyors United - Global Surveying Community

Votes: 0
Email me when people reply –

Replies

  • Hi Grodon,

    Over the years how much servicing was done to the Instrument. Has it been cleaned and all the 

    electrical contacts been cleaned. It seems like corrosion from moisture maybe,over the years,

    even kept dry ,it can built up.How many times has it got wet or worked in wet conditions.

    There may be part that needs changing,but I first look at cleaning all the contacts. You said both power methods show the same results,so it maybe internal connections. I start where it is good  and trace it to the instrument, Do you have away to check volts,amps, and mil amps on the battery handle and the adapter .You may need to take it in for a service check and a tech look at it.

    • Retired Surveyor

      Thanks for the reply Billy and apologies for not answering sooner. I took the GTS-4 to the local TOPCON dealer in Santiago, Chile, and he gave me the same response. He passed it to a technical person whoc couldn't find the problem ( though I doubt he tried very hard). I last used the instrument over 18 months ago and it has been in its case ever since. Chile is a dry desert country and humidity is rarely a problem.

      The Topcon dealer said the GTS-4 is obsolete and wanted to interest me in a new model, which for the times I use it, is out of the question.He mentioned that the circuit boards for that model would no longer be available.

      However, if I could get a map of the circuit boards, that might help to locate the problem!

      Thanks again,

      Grodon Siddeley

      •   Hi Grodon, 

         I knew part of Chile is dry,but moisture may not be the problem. Did you try cleaning the contacts , with something like alcohol and q-tip then let it dry. There could be something very well wrong electrically. They always try to sell you another gun. I have a old TS, am  lucky that it is still okay.  But it works as well as a new one to me,and it is made a lot better than one you can buy. Sorry for your problem,maybe you can get it fixed anyway. It is hard to reason that somewhere there is not that part, in some warehouse somewhere.

         Stay in touch, glad to have met you.

        Best Regards,

        Billy

This reply was deleted.