Follow Leica Geosystems Hub

This group is for Land Surveyors United members who use Leica Geosystems Surveying Instruments in the field. This group is for discussions and tutorials related to Leica user. Land Surveyors United is not directly affiliated with Leica and all logos and imagery are copyright of their respective owners.

224 Members
👉️Join this Hub
Land Surveyor

RTK Leica GX1230 with GFU7(Siemens M20)

Am trying to use the old fashioned RTK with GSM. I use a GX1230 with Siemens M20 (GX1230 Tech Ref Manual lists M20 as a supported model). Connected the M20 to Port1, configured the Real Time Interface with Port1 and Siemens M20 that shows up by default in Smartworx with factory default AT commands. I create a Config Set for Rover, all done and Smartworx shows messages, 1. Config Set saved, 2. Port1: No response from GSM and 3.Port1: GSM Initialised. The SIM I use has both voice and data from the service provider. I do not have a Network RTK Infrastructure, so I am doing a Single Base to Single Rover RTK. Under Additional Rover Option, Accept Reference is "Any Received" and Ref Network is "None" (as I dont have a Network RTK Infrastructure).

Begin Survey, Press F3 CONEC, Screen shows Dialling 'mobile number', and immediately, it throws up 'Connection interrupted' error in Smartworx.

When I use AT commands on M20, I am able to call my mobile (rings) and from my mobile to the M20 unit, smartworx displays connection established. But its when I dial via smartworx, from Rover to Base, smartworx throws up this error almost immediately. Have struggled with it for 2 weeks.

Appreciate if you can throw some light. Thank you.

You need to be a member of Land Surveyors United - Global Surveying Community to add thoughts!

Join Land Surveyors United - Global Surveying Community

Votes: 0
Email me when people reply –

Replies

  • Land Surveyor

    I suppose the problem in cellular network operator, but may be I am wrong. I had problem: I struggled with the same problem about 2 years ago. I had leica 1230 GG and GFU24 (Siemens MC 75) through GSM channel . And I had the same message Port: Connection interrupted... The problem was in my cellular network operator because it didn't support CSD (Circuit Switched Data) - old tech. I changed operator, acquired old sim-card and spoke to mobile operator support about this problem. After 2 days my RTK had worked.

    • Land Surveyor

      Thank you for the advice Vova. I will try.

      • Land Surveyor

        Hi Vova,

        I tried a few experiments but not successful. I was able to call my mobile from the M20 and from my mobile to M20. But it does not go beyond the handshake. Then I spoke to my GSM network operator - he said - "this CSD technology on M20 is very very old (2003, 2004). We have shifted to advanced systems on our Digital exchanges, therefore CSD with background WAP 1.0 is not supported by us now".

        So that's how it turned up. :(

        Thanks anyway.

        Ragavan

This reply was deleted.

Hey there!
It looks like you are enjoying the community content.

That's nice! Please don't forget to mention us if you use what you just copied on your website. Help strenthen the community by linking back to us!


Thank you very much! Have a nice day! :)

Ok. Don't bother me again, for this session.