I have a big problem with Leica 805 power. After a faulty update. the machine turn on and keep beeping with a error message 'FATAL ERROR". I'm working in the middle of the desert and I must fix it. Can you please help me to put the total station to upload mode in order to load the firmware. Any help will b appreciated.

Best regards

This Content Originally Published by a land surveyor to Land Surveyors United Network

Views: 1102

See Your Saved Posts Timeline

Replies to This Discussion

Take a look at the attached document and let us know if it helps.. there is a section about Fatal errors..

Download Survey Documents-Members Only
Was this resource helpful? Show your appreciation with a comment below. 

Donations are how we exist and grow for the surveying community worldwide.

Hello Adil, I just look at my manual,  it does not give that exact error message  ,only system error,and fault error, on these it says service department. But have you tried to access the menu, have you remove the batteries and cut the instrument on,Some times you can short the batteries contact of course batteries remove and turn instrument on , this will reset and clear all null bites in program memory have you tried to hold down the menu key and push the on button and release at same time.And try this ,cut the gun off and press each key one at a time and push the on button and release at same time,also try pushing two keys and on button at the same time then release. Manual do not always give access direction to instrument configuration  menu, the companies stop doing this. You said you were applying  a update , was this off the internet  from Leica site.what method was you using,and the upgrade failed.and now the instrument want initialize,i know you turn the barrel to start the program ,and the gun stays on but shows error and beeps , so this is not a power problem the gun is staying on. You may have a main frame program error .In this case only a service department can fix it.the program has to be reinstalled,I do not think they down load this you, but go on line get their contact phone, if they can not help you on line maybe you can talk to someone on the phone.


Hello Adil,  What is this firmware  you speak of , is this a cd, dvd  are some other format, is this what cause the problem ,or is this the same program or the original program, or a back up  to install on the instrument. The cmos may have a problem. some times you have to have cd or dvd to get to this setup program. but  i do not know because the gun will not initialize. but some times you need the setup disk to fix this, since you can not  access the menu to go to upload mode this may be the only way  , but do  what i told you to do first, if you can get the menu to come up you can go to upload mode.


Hello again Adil, I like to know if you have a manual to this instrument.The keys i want you to hold down  and turn on or the yellow this is the input keys, next or the orange this is program and functions. Are yours this color, and are the fix keys grey and the control keys green.the  prog. key  calls up on board apps. menu key calls main menu, short press. and a long press calls up configuration menu is this how yours works. Have you  tried pressing the  ESC key this should stop all function and delete error messages . this will also interrupts active  function. Do know how to clear all memory  if you can get to it. let me know what you find out it my help me.



Thank you for your answer.I couldn't find anything about my issue in that document as it"s all about disto and I have a leica TCR805 total station. I need a way to reloid the firmware into the machine. It must be a key combination or something to put it back to upload mode.  For now it turn one and get stuck on "BOOT DETECTION ERROR,SAPP/TOPS overlap, Fatal error". Help please !!

Hello Adil, Have you tried going to the Leica web site and getting technical support. There has to be a way to

reset back to default setting, on boot  Go here they have always help me.



Hello Billy, thank you for the link,Yes I tried every combination but no success (I didn't try to short-cut the battery, I don't want to make it worse). I don't know exactly how to clear memory as the machine is stuck on that screen. I pretty sure there is a way to fix it I just need to know how to put it back into upload mode

Download Survey Documents-Members Only
Was this resource helpful? Show your appreciation with a comment below. 

Donations are how we exist and grow for the surveying community worldwide.

Hello Adil,  I did not want you to do anything to the batteries I am talking about the contacts on the instrument. You remove the batteries ,now there is no electricity  now. So this can not hurt the instrument because no power is going through it understand.  Now take a paper clip or any metal object like wire, I have even use coins, (when they are close ) that conducts elect. now touch the contacts on the instrument  and press the on button.  Any time you remove the batteries out of the instrument  or any electrical device that has a stored memory it has a capacitor this has a small electrical charge, this is a DC current, this is what keeps your memory from being erased. what you are doing is cutting it off. I have used paper clips because most of the time you have one.When i used the HP 48gx calculator  as a data collector, it has a reset hole on the back ,you bend the clip strait and push it the the hole to reset the calculator so i have always had one. So this can be  bent to match the contacts on the instrument  This may or may not fix it but it worth the try, Sometimes this will fix the problem . But i think the cmos has become corrupted . I still like to know what this up grade was . You do not have a manual , when you get it fix  you need to get one Talk to Leica about that to, they may send you one.Only  a  registered  owner,sales person or repair tech can download it.Sorry about your problem some times there are things you can not fix in the field . You need to learn  how to clear the memory this means there are a lot of null bites stored in the gun if it has not been clear in a long time, it needs to be cleared this will make It work better and faster. when you get it fixed, i will help you with this. Also did you try pushing esc, also i just looked at your pic of the display  . i could not make out all of it,i could make out apps but tell me  what it says. after that. talk to you again soon.


Hello, I tried to short cut the contact of the station but nothing happened.The issue happened when I was tying to add another language to the machine and  the Pc went to sleep. I also tried many key combination but no success. 


HI  Adil, I still need to know every think that is wrote on the error boot message.All i can make out is app, something ...tops or top and it looks like over ride or over turn. I can not tell. but if it's what i think it says it, is talking about the program that waits for you to turn the barrel over has a problem talking to or talking back to start or to finish the boot. this means that something has happen to corrupted  the pathways  between the programs this is what it may be.Have you talk to anyone from Leica yet. The instructions i gave you on the keys or some they will not tell you in the manual. The main menu is where you clear all data, I think #4 or # 5  then,1,2,3  select, but i will help with that  when this problem is solve. Let me know what it said and what Leica tells you.


HI Adil, These key instruction are things that Leica will not tell you. They keep these instruction to themselves these are programs for the technician to use. They started keeping these to themselves  a few years ago , because  they did not want unqualified  people getting access to this programs.. Little things like grounding of contacts this also clears null bites so this helped although it did not help your problem. They keep things like this to themselves.  Your problem is with your software i do not think  it electrical or mechanical  although it could be. You may have to get another inst. and get this one fix. You never know what can go wrong, it may need a part. Electronics any thing can go wrong. But  when you get it going again let me know and i will help check all the settings and tell how to use the test programs and etc... clear all your data if it is not been done and the other settings.  If you want the help.   

keep in touch    billy.

hi Billy;

first of all, thank you for all your effort. i can not access the main menu as the machine give that message once I push the ON button "Boot detection error, SAPP_TOPS overlap, fatal error". I was trying to uploaad the firmware from my Pc when that happened. can you explain to me how I can get to the main menu on that machine ?



Where Thousands of Professional Land Surveyors, Students of Surveying and Educators are United through Collaborative Knowledge and Purpose.

Tools,Apps and Quick Guides


Help With Survey Equipment

Social Support For Equipment

Surveying Video Categories

Surveying Photo Categories

United States Hub Forums

International Surveyor Hub Forums

Resources for Company Owners

Land Surveyor Social Media

Surveyor Resources Collections

Getting Started & Newsletter

© 2018   © Created by Land Surveyors United   Powered by

Badges  |  Contact LSU  |  Privacy Policy  |  Terms of Service